Der Nachfolger des WDR-Computerclub mit Wolfgang Back und Wolfgang Rudolph - ...und immer ein Bit übrigbehalten!


Das Forum zur C-Control-1
Welche C-Control-Varianten existieren?
Übersicht - Suchen - Neueste 50 Beiträge - Neuer Beitrag - Login - Registrieren
INFO - FAQ - CC2-Forum - CCPro-Forum 

 Syscode Open-Macro Kategorie: Open-Micro/Open-Mini/Open-Midi/Open-Macro/Open-Maxi (von Hanspeter Roth - 22.10.2018 16:26)
Hanspeter Roth nutzt:  CC1-Unit V1.1, Open-Mini, Open-Midi, Open-Macro, Open-Maxi
Hallo

Ich möchte beim Open-Macro  SYSCODE verwenden.

Hier ein einfaches Testprogramm:

' basic programm  (test.bas)

include "omac.def"

define ready              port [9]

ready=0

#main

sys &hfd00               ' aufruf der assembler routiene
pause 3
goto main

syscode "timing.s19"

Und hier die in Assembler und s19 gewandelte "timing.bas" Routiene :

' als syscode verwendet  (timing.bas)

define ready              port [9]

#start_loop

ready=1           ' port ON

pause 10

ready=0           ' Port OFF

return            ' das wars schon

Und was passiert ?:

Kein Problem beim Kompilieren, s19 Erstellen und Laden. Beim Ausführen jedoch versickert das
Programm langsam in der SYS-Routiene. Auf dem Starterboard fangen alle LED's an zu leuchten, so
als würden sie mit einem Dimmer hochgefahren.

Kurios .. nicht ? Was könnte das sein, oder was mache ich falsch ?

Gruss
Hanspeter

 Antwort schreiben

Bisherige Antworten:

Re: Syscode Open-Macro (von Dietmar - 22.10.2018 16:36)
    Re: Syscode Open-Macro (von Hanspeter Roth - 22.10.2018 17:11)
        Re: Syscode Open-Macro (von Dietmar - 22.10.2018 17:18)
            Re: Syscode Open-Macro (von Hanspeter Roth - 22.10.2018 18:01)