Das Open-Control-Projekt - Die Alternative zur C-Control-I


Das Forum zur C-Control-1
Welche C-Control-Varianten existieren?
Übersicht - Suchen - Neueste 50 Beiträge - Neuer Beitrag - Login - Registrieren
INFO - FAQ - CC2-Forum - CCPro-Forum 

 Re: Eingänge PCF 8574 Kategorie: Hardware (von chuckie - 19.03.2007 17:34)
 Als Antwort auf Re: Eingänge PCF 8574 von Todi - 19.03.2007 16:56
chuckie nutzt:  CC1-M-Unit V1.2/2.0
ne nur die Bus-Leitung verbindet die unit mit pcf 8574 und 5v & 0v natürlich auch...  
ja das stimmt, nur das war als beispiel gemeint....
ich probiere es gleich mal.... nur das komische ist ja das die lcd displays die mit nem pcf 8574 gekoppelt sind und die relais einwahnfrei funktionieren  wenn ich z.b.
den port [5] als taster nehme, natürlich nur mit 5V als eingang dann schaltet das relai...


> Hallo,
>
> mal abgesehen davon, dass das Relais nur solange schaltet wie der Taster gedrückt ist und man dann auch
>
> relai1 = Taste1
>
> schreiben könnte, habe ich zeitweise dasselbe Problem (siehe Beitrag "I2C-Verlängerung").
> Ist an deinem PCF8574 der Interrupt-Pin mit der Unit verbunden?
> Hast du mal versucht,
> LCD.INIT
> LCD.OFF
> SDA=on
> SCL=on
> zu tauschen, also so:
> SDA=on
> SCL=on
> LCD.INIT
> LCD.OFF
>
> MfG
> Todi
>
> > > Ich will einen PCF 8574 als eingänge benutzten, mit tastern die auf die eingänge masse (0V) geben.
> > > Wenn ich z.b. Taster 1 (port 80) drücke soll der port 65 geschaltet werden.
> > >
> > > define tasten as byteport[10]
> > > define taste1 as port[80]
> > > define relai1 as port[65]
> > > define SDA port[9]
> > > define SCL port[10]
> > >
> > >
> > > LCD.INIT
> > > LCD.OFF
> > > SDA=on
> > > SCL=on
> > >
> > > tasten=11111111b
> > >
> >   #loop (sry hatte ich vergessen. nachtrag)
> > > if taste1=off then
> > > relai1=on
> > > else
> > > relai=off
> > > end if
> > >
> > > goto loop (sry hatte ich hier vergessen)
> >
> > > Irgendwie funktioniert das aber nich, so als würde der pcf garnicht erkennen das der port 80 (7) aus low gesenkt wurde.. das relai bleibt auf off.
> > >
> > > Wenn ich mit einem messgerät von port 80 gegen masse messe hab ich 5 Volt (4,95V) wenn ich den byteport 10 auf 0 setzte hab ich 0 volt anzeige  als das funktioniert, kaputt ist der chip net.. Das trägt umsomehr zu meiner verzweiflung bei.... kann mir jemand helfen

 Antwort schreiben

Bisherige Antworten:

Re: Eingänge PCF 8574 (von Todi - 19.03.2007 17:57)
    Re: Eingänge PCF 8574 (von chuckie - 20.03.2007 18:04)
        Re: Eingänge PCF 8574 (von gerd - 21.03.2007 12:32)