Der Nachfolger des WDR-Computerclub mit Wolfgang Back und Wolfgang Rudolph - ...und immer ein Bit übrigbehalten!


Das Forum zur C-Control-1
Welche C-Control-Varianten existieren?
Übersicht - Suchen - Neueste 50 Beiträge - Neuer Beitrag - Login - Registrieren
INFO - FAQ - CC2-Forum - CCPro-Forum 

 Re: Ports Impulse beim Einschalten der Betriebsspannung Kategorie: C-Control I V1.2/2.0 (von Jürgen - 15.04.2008 8:10)
 Als Antwort auf Re: Ports Impulse beim Einschalten der Betriebsspannung von Thomas Wulf - 10.04.2008 10:50
> > Hallo liebe Gemeinde,
> >
> > wenn ich mein M2.0 Unit einschalte (Spannung anlege) so erkenne ich am Oszi kurze positive Impulse von ein paar 100us Dauer an den Ports. Diese sind mit 1kOhm belastbar ohne deutlich zusammenzubrechen. Die Ports sind also für kurze Zeit niederohmige Ausgänge, es sind nicht die internen Pullups und auch nicht die Glitches die im Forum schon mal behandelt wurden. Ich kann die Impulse sogar einwandfrei optisch mit LED warnehmen. die LEDs sind mit 680 Ohm gegen Masse geschaltet. Wer kennt das Problem und wer kann mir Tips geben um diesen Effekt zu vermeiden.
> >
> > Vielen Dank,
> >
> > Thomas
>
>
> Hallo noch ein Nachtrag :
>
> Es sind nur die Ports 9 und 10 betroffen. Vermutlich hat das was mit der opptionalen IIC Schnittstelle zu tun. Während des Reset sind die Ports low (hochohmig) und nach dem Reset (kein Start gedrückt) wieder niederohmig mit high-level. Was kann man hier tun um solches zu verhindern ?
>
> Gruss, Thomas


Hallo,

Jenachdem welche Version Du hast, ich glaube ab 2.05 kann man die Unit auch über Chipkarte programmieren, das heißt beim anlegen der Spannung schaut er nach ob ein Chipkartenleser angeschlossen ist.
Mit dem programm "CCBAS_SET_BOOTMODE_OFF"kann man das ausschalten, das heißt er lässt sich nur noch über die Schnittstelle programmieren.


Vielleicht klappt es

Gruß Jürgen

Passender Link: C-Control

 Antwort schreiben

Bisherige Antworten:

Re: Ports Impulse beim Einschalten der Betriebsspannung (von Thomas Wulf - 16.04.2008 13:43)
Re: Ports Impulse beim Einschalten der Betriebsspannung (von Thomas Wulf - 16.04.2008 8:56)