Der Nachfolger des WDR-Computerclub mit Wolfgang Back und Wolfgang Rudolph - ...und immer ein Bit übrigbehalten!


Das Forum zur C-Control-1
Welche C-Control-Varianten existieren?
Übersicht - Suchen - Neueste 50 Beiträge - Neuer Beitrag - Login - Registrieren
INFO - FAQ - CC2-Forum - CCPro-Forum 

 Re: Folgender Code funzt nicht Kategorie: Programmierung Basic (von Feynthefallen - 14.08.2006 21:53)
 Als Antwort auf Re: Folgender Code funzt nicht von Dietmar - 14.08.2006 19:57
Feynthefallen nutzt:  Open-Micro, Open-Mini
> Hallo Tom!
>
> > Möglicherweise speichert die erst dann vernünftig wenn man die Datei schließt.
>
> Zumindest reicht es in der CCBASIC-Windows-IDE nicht, den Quellcode nur zu compilieren. Vor dem Compilieren wird nämlich nicht gespeichert. Aber nach Strg+S sollte eigentlich schon der korrekte Quellcode auf der Platte stehen. Schließen sollte nicht notwendig sein.

Dann würde ich darauf tippen.  Ich weiß nicht, ob ich nur compiliert oder tatsächlich auf speichern geklickt hab.
>
> > es war früh am morgen und ich hatte noch keinen Kaffee drin...;-)
>
> Dann halte ich es am wahrscheinlichsten, daß Du einfach aus der 34 eine 24 gelesen hast. :-) Oder Du hast beim Aufruf an der Kommandozeile Dateinamen vertauscht.

Nein DAS war ja Abends... Halt nein das war morgens... aber VOR dem Schlafen, da bin ich am fittesten :-)))
Und ja, ich weiß ganz sicher, daß ich 24 gesehen habe. Außerdem wäre sonst nicht zu erklären, weshalb der Code dann nicht lief. Simulieren ließ er sich nämlich einwandfrei.
>
> Was genau funktionierte denn nicht? Wenn Du "ctr = bport shl 1" schreibst, funktioniert das Lauflicht beispielsweise nicht mehr.
Ich kann dir nicht sagen, was nicht ging. Es tat sich einfach garnichts. Wie gesagt, simulieren ließ es sich.

-Tom

Bin derzeit in der Klinik, daher kann es mit den Antworten länger dauern.

There's nothing so inventive as a fool tampering with a foolproof appliance

 Antwort schreiben

Bisherige Antworten:

Simulator (von Dietmar - 16.08.2006 12:34)