Das Open-Control-Projekt - Die Alternative zur C-Control-I


Das Forum zur C-Control-1
Welche C-Control-Varianten existieren?
Übersicht - Suchen - Neueste 50 Beiträge - Neuer Beitrag - Login - Registrieren
INFO - FAQ - CC2-Forum - CCPro-Forum 

 Re: Open Macro defekt? Kategorie: Open-Micro/Open-Mini/Open-Midi/Open-Macro/Open-Maxi (von Laika - 10.03.2024 14:57)
 Als Antwort auf Re: Open Macro defekt? von Dietmar - 7.03.2024 1:47
Hallo Dietmar,

nach einer Weile - ich besch├Ąftige mich nicht st├Ąndig damit - eine Antwort.
> vielleicht sendet die Open-Macro viele BYTE-Daten hintereinander und der Empf├Ąnger kann nicht synchronisieren?
Das ging bisher immer, sowohl am PC als auch Laptop. Auf beiden mit Hyperterminal und VBA. Weiss nicht, wann es gekippt ist.
Das Merkw├╝rdige ist, dass die Macro einwandfrei mit dem Prpgramm, dass ich fr├╝her mal geladen hatte, l├Ąuft, dass es richtig auf Tasten reagiert und auch auf Bedienungen (├╝ber ESCI). Aber die Antwort auf Letzteres ist der genannte Kauderwelsch. Sie reagiert auch richtig auf das Kommando f├╝r End2Host, bleibt dann stehen, aber das Laden eines Programms mit OMLDWIN geht nicht: "Keine Antwort vom Controller". dabei ist es egal, ob ├╝ber Port 3 Run- oder Hostmode nach Reset eingestellt ist.

> Was passiert denn, wenn Du den Hostmode-Schalter in Stellung "Host" schaltest, also auf Masse und versuchst, ein neues Programm zu ├╝bertragen?
s.o.
 
> PORT[3] ist allerdings nur als Eingang zu verwenden und bei dessen Beschaltung ist zu beachten, da├č dieser Port zugleich als HOST/RUN-Pin dient. Nach einem Reset mu├č dieser Pin auf High-Potential (5 Volt) liegen, sonst arbeitet der Controller das Anwenderprogramm nicht ab, sondern geht in den Hostmodus.
Wenn Prot 3 auf Run steht, l├Ąuft der Controller an und arbeitet richtig. Der Port wird f├╝r nichts anderes verwendet.
 
Gr├╝├čle, Laika

 Antwort schreiben

Bisherige Antworten:

Re: Open Macro defekt? (von Dietmar - 10.03.2024 15:20)
    Re: Open Macro defekt? (von Laika - 10.03.2024 15:59)
        Re: Open Macro defekt? (von Dietmar - 10.03.2024 17:18)
            Re: Open Macro defekt? (von Laika - 15.03.2024 13:13)