Der Nachfolger des WDR-Computerclub mit Wolfgang Back und Wolfgang Rudolph - ...und immer ein Bit übrigbehalten!


Das Forum zur C-Control-1
Welche C-Control-Varianten existieren?
Übersicht - Suchen - Neueste 50 Beiträge - Neuer Beitrag - Login - Registrieren
INFO - FAQ - CC2-Forum - CCPro-Forum 

 Re: Analog-Ports Kategorie: C-Control I V1.1 (von Hanspeter - 5.03.2007 11:54)
 Als Antwort auf Re: Analog-Ports von ManfredW - 2.03.2007 13:38
Hanspeter nutzt:  CC1-M-Unit V1.1
> > Hallo, guten Tag
> >
> > Folgendes HW-Problem:
> >
> > Auf einem industriellen Print sind 2 C-Controller installiert.
> >
> > Feste Spannung an AD[x] angelegt (z.B. 2.5V) Ref.Spannung 5V.
> > Mit Digi-Voltmeter keine Schwankungen am AD-Port... und doch
> > die umgesetzten Werte flippern immer um 123..128..121..127..etc
> > herum. Und das nur bei einem Controller. Der zweite zeigt etwa 128..127..128 etc.
> > (die selbe Spannung geht an beide Controller!)
> > Kontroller gewechselt .. keine Aenderung!
> > Bei zwei Leiterplatten der selbe Effekt beim selben Controller..
> > Wo könnte das Problem liegen..entsprechende Kondensator an der Ref. und
> > Versorgungsspannung sind vorhanden..vielleicht schlecht platziert ???
> >
> > Besten Dank zum Voraus
> > Hanspeter
>
> Hallo,
>
> was heißt feste Spannung?
> Du kannst mit einer Batterie prüfen, um Netzspitzen auszuschließen.
> Ein Bit Schwankung sind nur ca. 0,02 Volt (2,5*1/128).
>
> MfG ManfredW

Hallo

Die Spannung kommt von einem Proportionalgeber aus einem Servoantrieb (hochstabil).
Auf der Leiterplatte sind 2 C-Controller vorhanden. Eigenartigerweise zeigt sich das
Problem nur bei einem Controller egal welcher Geber angeschlossen ist. Es ist immer
der selbe Chip, welcher Zappelwerte ausgibt. Und wie gesagt, ein angeschlossenes DigiMeter
oder KO zeigen keinerlei Unregelmässigkeiten am Eingangssignal.
Dabei werde ich das Gefühl nicht los, dass ich irgend ein Pin des Chips nicht richtig (Potential) an-
geschlossen  habe. Ein Schaltplan, welcher der C-Unit beigelegt war zeigt zwar die Anschlüsse
aber ganz klar sind nicht alle Pins definiert. z.B Pin 6 & 15 sind als intern NC (not connected)
bezeichnet, ausserhalb wird aber +VCC verlangt. Zum Testen oder kreieren einer Schaltung
benütze ich das Starterboard. Schliesse ich den Geberausgang an einen AD-Wandler Eingang
des Starterboards , so habe ich absolut ruhige Werte. Aus diesem Grund habe ich sämtliche
Pins welche im Schaltplan nicht klar definiert sind am Processor des Starterboards gemessen
und auf der Leiterplatte nachvollzogen. Bis jetzt leider ohne EINDEUTIGEN Erfolg.

Ist doch eigenartig ??

MFG
H.P. Roth

 Antwort schreiben

Bisherige Antworten:

Re: Analog-Ports (von Hauk - 6.03.2007 0:51)
    Re: Analog-Ports (von Hanspeter - 6.03.2007 11:36)