Das Open-Control-Projekt - Die Alternative zur C-Control-I


Das Forum zur C-Control-1
Welche C-Control-Varianten existieren?
Übersicht - Suchen - Neueste 50 Beiträge - Neuer Beitrag - Login - Registrieren
INFO - FAQ - CC2-Forum - CCPro-Forum 

 Re: Control Station-Temperaturmeßproblem !!! Kategorie: C-Control I V1.1 (von TomTom - 27.03.2004 21:52)
 Als Antwort auf Re: Control Station-Temperaturmeßproblem !!! von Markus - 27.03.2004 21:16
> > > BITTE UM HILFE! Ich (blutiger Anf├Ąnger) habe ein Problem, das ich leider rasch l├Âsen
> > > mu├č. Vorhanden: C-Control Station. Schalten von Relaise per C-Basic-Prog.
> > > funktioniert.
> > > 1)Ich bekomme nicht ┬┤raus, wie ich die Temperatur ├╝ber die beiden
> > > mitgelieferten Me├čf├╝hler per CCBasic-Programm richtig angezeigt bekomme (Ergebnis ist
> > > immer NULL). Das Beispielprogramm auf der Diskette funktioniert nicht.
> > > RS232-Verbindung o.k., Me├čf├╝hler werksseitig angeschlossen.
> > > Gibt es ein idiotensicheres listing?
> > > Das w├Ąre das Wichtigste.
> > > 2)Print-Befehlsausgabe funktioniert nur im Probelauf, nicht ├╝ber das
> > > Programm in der Station. Ausgabe nur auf DOS-Ebene?
> > > 3)Was brauche ich an Hardware, um ├╝ber Com2 od. Com1 per QBasic (!)
> > > Temperaturanzeigen (┬░C) in den PC zu bekommen und wie sag ichs meinem Computer?
> > >
> > > Ich w├Ąre m├Ąchtig dankbar, wenn ihr mir mir da helfen k├Ânntet....
> > > MfG
> > > Markus
> > > boku17@gmx.at
> > >
> > Hallo,
> >
> > Zu 1)  schau auf meine homepage unter Softwarebausteine.
> > Dort ist die Temperaturmessung mit den Me├čf├╝hlern der Station beschrieben.
> >
> > MfG ManfredW
>
> Vielen Dank. ├ťbrigens: Exzelente Homepage! NUR:  Ich kapiers trotzdem nicht.
> Das Problem besteht weiterhin. Die Temperaturabfrage wie in der Homepage beschrieben
> ergibt -25 ┬░C.
> Kann man im Entwicklungs-Editor von CCBasic die Temperaturf├╝hler tats├Ąchlich abfragen?
> Soda├č "print temperatur" tats├Ąchlich die ├╝ber die F├╝hler gemessene Temperatur ausgibt?
> Sonst kann ich ja nicht testen, ob das Programm richtig mi├čt oder ob ein F├╝hler kaputt ist.
>
> Tut leid, f├╝r einen, der sich gut auskennt, ist das wahrscheinlich ein l├Ącherliches Problem, f├╝r
> f├╝r mich aber ein ganz gro├čes....
>
> Beste Gr├╝├če
> Markus
>
Hallo Markus!
Bin selber Anf├Ąnger und hatte dasselbe Prob.
1. Beim Simulieren wird das Programm auf dem PC abgearbeitet. Da k├Ânnen die an die Station
    geschlossenen TempF├╝hler nicht funktionieren. Da gibts dann aber auch ein eigenes Fenster,
    in dem Du die Analogwerte von Hand einstellen kannst (also auch die TempF├╝hler simulieren).
2. Hast Du das Programm erstmal auf die Station ├╝bertragen, so sendet sie Zeichen ├╝ber sie
    (jetzt echte!) serielle Schnittstelle. Um die anzuzeigen brauchst Du Hyperterm. D├ís is beim
    Windows dabei. Das Terminal empf├Ąngt die Daten und macht sie auf dem Bildschirm sichtbar.
    Mit der Entwicklungsumgebung geht das "in Echt" nicht mehr!

Mfg
TomTom

 Antwort schreiben

Bisherige Antworten:

Re: Control Station-Temperaturmeßproblem !!! (von Markus - 28.03.2004 17:07)
    Re: Control Station-Temperaturmeßproblem !!! (von TomTom - 28.03.2004 17:51)
        Re: Control Station-Temperaturmeßproblem !!! (von Markus - 14.04.2004 23:12)
            Re: Control Station-Temperaturmeßproblem !!! (von Willi aus Oelde - 16.04.2004 0:08)
                Re: Control Station-Temperaturmeßproblem !!! (von Markus - 21.04.2004 18:18)
                    Re: Control Station-Temperaturmeßproblem !!! (von Markus - 11.04.2009 16:08)